Wave: Issue when ordering digital ads on social media

Incident Report for BROKER

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 18:34 CEST

Identified

We are currently working on the fix
Posted Jun 05, 2026 - 15:18 CEST
This incident affected: Wave.